匯出與列印
VMark 提供多種文件匯出與分享方式。
匯出產生的內容
檔案 → 匯出 → HTML 會寫出一個以文件命名的資料夾,其中一定同時包含以下兩個檔案 — 沒有模式需要選擇:
MyDocument/
├── index.html ← 連結到 assets/ 底下的檔案
├── standalone.html ← 所有內容都以 data URI 嵌入(CSS、JS、圖片、字型)
└── assets/
├── vmark-reader.css
├── vmark-reader.js
├── images/
│ ├── image1.png
│ └── ...
└── fonts/ ← 僅在文件含有數學公式或你使用網頁字型時產生依當下需求選用任一檔案:
| 檔案 | 最適合 | 取捨 |
|---|---|---|
index.html | 托管在靜態網站上(簡潔的 /MyDocument/ URL)、在其他工具中編輯、控制檔案大小 | 需要旁邊的 assets/ 資料夾 |
standalone.html | 以電子郵件或訊息傳送一個不會遺失圖片的單一檔案 | 較大 — 每項資產都內嵌其中 |
兩個檔案都使用與編輯器相同的所見即所得算繪器與樣式表進行算繪,也都包含 VMark 閱讀器。
如何匯出
匯出 HTML
- 使用 檔案 → 匯出 → HTML
- 選擇儲存位置並輸入名稱 — 它會成為資料夾名稱(結尾的
.html會被移除) - 從新資料夾中開啟
index.html或standalone.html
重新匯出到曾經使用過的資料夾
HTML 匯出是全有或全無的。所有內容會先寫入你所選目的地中的一個暫存 .vmark-export-… 資料夾,等每個檔案都存在後才移到定位 — 因此中途失敗的匯出會讓上一次的匯出保持原樣,而不會只覆寫一半。
你可能會看到兩種情況:
- 「另一個匯出正在寫入此資料夾。」 同一時間只能有一個匯出寫入同一個資料夾,跨視窗亦然。請等待另一個匯出完成;或者 — 如果沒有其他匯出在執行 — 刪除訊息中提到的
.vmark-export.lock檔案後再試一次。 - 留下了一個
.vmark-export-…資料夾。 VMark 完成後會移除它。只有在把你先前的檔案放回原處也失敗時,它才會保留下來;此時它存放著那些檔案,錯誤訊息會明確指出它們的位置。在它是唯一副本的情況下,不會刪除任何內容。
列印 / 匯出 PDF
適用於 macOS、Windows 與 Linux。
匯出 PDF(檔案 → 匯出 → PDF)會直接寫出 PDF,使用你在匯出對話框中選擇的紙張大小、方向、邊距與排版。
列印(Cmd/Ctrl + P,或 檔案 → 列印...)則會開啟系統列印對話框,讓你將文件送到印表機,或使用作業系統本身的「另存為 PDF」。在 macOS 與 Linux 上,列印工作完成時 VMark 會顯示簡短的提示,若你取消對話框則不會有任何提示;Windows 的列印介面不會回報結果,因此那裡不會顯示提示。
匯出對話框在三個平台上都會顯示相同的進度階段 — 載入、產生、完成中、完成。
macOS 上的紙張大小
你在對話框中選擇的紙張大小與方向,在每個平台上都決定匯出的頁面。在 macOS 上,它們會覆蓋系統設定的紙張大小 — 如果你的 Mac 預設為 Letter 而你選擇 A4,PDF 就會是 A4。
側邊欄大綱。 在三個平台上,匯出的 PDF 都帶有標題大綱 — 也就是 PDF 檢視器在側邊欄顯示的可點擊目錄。
頁碼
對話框中的 頁碼 區段會為每一頁加上頁碼。預設開啟,位於底部置中。
| 設定 | 選項 |
|---|---|
| 位置 | 底部置中、底部右側或無 |
| 格式 | 7、7 / 12 或 第 7 頁,共 12 頁 |
| 略過首頁 | 第 1 頁不加頁碼,這是標題頁的常見處理方式 |
頁碼位於你所選的底部邊距內,並隨內文字型大小縮放。頁碼一律反映實際頁序,因此略過首頁後,後續頁面會是 2、3、4……,而不會重新編號。
頁碼使用拉丁字母
頁碼以任何檢視器都不必下載的標準 PDF 字型繪製,這正是匯出能快速且自成一體的原因 — 但該字型無法呈現中文、日文、韓文或西里爾字母。兩種純數字格式在任何語言下都能正常使用。如果你的介面語言以該字型無法繪製的文字書寫 第 7 頁,共 12 頁 這類格式,VMark 會改為印出數字形式的 7 / 12,而不是空白或錯誤的字元。
匯出至其他格式
VMark 整合了 Pandoc — 通用文件轉換器 — 可將 Markdown 匯出至其他格式。直接從選單中選擇格式:
檔案 → 匯出 → 透過 Pandoc →
| 選單項目 | 副檔名 |
|---|---|
| Word (.docx) | .docx |
| EPUB (.epub) | .epub |
| LaTeX (.tex) | .tex |
| OpenDocument (.odt) | .odt |
| 格式化文字 (.rtf) | .rtf |
| 純文字 (.txt) | .txt |
設定:
- 從 pandoc.org/installing 安裝 Pandoc,或透過套件管理器安裝:
- macOS:
brew install pandoc - Windows:
winget install pandoc - Linux:
apt install pandoc
- macOS:
- 重新啟動 VMark(或至 設定 → 檔案與圖片 → 文件工具 並點選 偵測)
- 使用 檔案 → 匯出 → 透過 Pandoc → [格式] 進行匯出
如果未安裝 Pandoc,透過 Pandoc 子選單只會顯示一個項目 — 「安裝 Pandoc 以匯出 Word、EPUB、LaTeX…」 — 點選後會開啟 Pandoc 安裝指南。
你可以在 設定 → 檔案與圖片 → 文件工具 中確認 Pandoc 是否已被偵測到。
複製為 HTML
按 Cmd/Ctrl + Shift + C,將渲染後的文件以 HTML 原始碼形式複製。標記會以純文字、不帶樣式的方式放入剪貼簿,因此請貼到預期接收 HTML 程式碼的地方 — 例如 CMS 的 HTML 檢視、範本或程式碼編輯器;Word 或「郵件」等富文字編輯器會直接顯示這些標籤。本機圖片會以 data URI 嵌入,因此 HTML 離開 VMark 後仍能正常顯示。
VMark 閱讀器
每個 HTML 匯出都包含 VMark 閱讀器 — 一個擁有專屬設定、導覽與燈箱的互動式閱讀體驗。
設定面板
點選齒輪圖示(右下角)開啟設定面板;按 Esc 再次關閉。你的選擇會由瀏覽器記住(localStorage),因此下次開啟該檔案時仍會套用。
| 設定 | 選項 |
|---|---|
| 字型大小 | 12px – 28px |
| 行距 | 1.2 – 2.4 |
| 內容寬度 | 30em – 80em |
| 西文字型 | System、Athelas、Palatino、Georgia、Charter、Literata |
| 中日韓字型 | System、PingFang、Songti、Kaiti、Noto Serif、Source Han |
| 主題 | White、Paper(預設)、Mint、Sepia、Night |
| 中日韓字距 | 0.02em – 0.12em |
| 中英文間距 | 切換中日韓文與拉丁文字元之間的自動間距 |
| 目錄 | 切換目錄側邊欄(與按 T 相同) |
| 展開所有區段 | 開啟每個可折疊的 <details> 區塊 |
| 重設為預設值 | 將所有設定恢復原狀 |
目錄
目錄側邊欄有助於在長文件中導覽:
- 切換:點選頁面邊緣的標籤或按
T - 導覽:點選任意標題跳至該處
- 高亮:滾動時,當前章節會被高亮顯示
閱讀進度
頁面頂部有一條細微的進度條,顯示你在文件中的閱讀進度。
返回頂部
向下滾動時會出現一個浮動按鈕。點選它即可返回頂部。
圖片燈箱
點選任意圖片可在全螢幕燈箱中檢視:
- 關閉:點選外部、按
Esc或點選 X 按鈕 - 縮放:圖片以原始大小顯示
程式碼區塊
每個程式碼區塊包含互動式控制項:
| 按鈕 | 功能 |
|---|---|
| 行號切換 | 顯示/隱藏此區塊的行號 |
| 複製按鈕 | 將程式碼複製至剪貼簿 |
複製成功時,複製按鈕會顯示勾選標記。
腳注導覽
腳注完全支援互動:
- 點選腳注參考
[1]跳至其定義 - 點選
↩反向連結返回你正在閱讀的位置
鍵盤快捷鍵
| 按鍵 | 操作 |
|---|---|
Esc | 關閉設定面板或燈箱 |
T | 切換目錄 |
+ / = | 放大字型 |
- | 縮小字型 |
匯出快捷鍵
| 操作 | 快捷鍵 |
|---|---|
| 匯出 HTML | (僅限選單) |
| 匯出 PDF | (僅限選單) |
| 列印 | Mod + P |
| 複製為 HTML | Mod + Shift + C |
提示
提供匯出的 HTML
資料夾匯出結構適用於任何靜態檔案伺服器:
# Python
cd MyDocument && python -m http.server 8000
# Node.js (npx)
npx serve MyDocument
# 直接開啟
open MyDocument/index.html離線檢視
兩個檔案都可離線開啟,但含有數學公式的文件有一點差異:
standalone.html完全自成一體 — KaTeX 樣式表與字型在匯出時就已內嵌,因此不需連線也能算繪數學公式。index.html會從 CDN(jsDelivr)載入 KaTeX 樣式表,因此開啟頁面時其數學公式需要網際網路連線;閱讀器、圖片以及assets/底下的字型則都在本機。
字型會在匯出時下載(KaTeX 字型,以及你在設定中選擇的任何網頁字型),因此若想把它們嵌入,請在可連上網際網路的電腦上匯出 — 離線匯出會退回使用系統字型。
哪些圖片會被嵌入
匯出的檔案帶有真實的圖片位元組,而匯出檔案會被分享出去 — 因此 VMark 會限制這些位元組可以來自哪裡:
| 你的文件…… | 圖片可以來自 |
|---|---|
| 位於已開啟的工作區內 | 該工作區中的任何位置 |
| 單獨開啟 | 文件本身所在的資料夾及其子資料夾 |
相對路徑從文件所在的資料夾解析,與編輯器中完全相同 — 因此只要目標仍在上述範圍內,../images/photo.png 就能正常運作。範圍以外的任何內容(~/.ssh/id_rsa、/etc/passwd、磁碟上其他位置的絕對路徑)都會被拒絕,並匯出為「Image not found」預留圖,計入匯出的警告中。
如果某張 ../ 圖片被匯出為預留圖,請將其所在資料夾作為工作區開啟,然後再匯出一次。
最佳實務
- 托管
index.html用於要發佈的文件 — 並將assets/資料夾放在它旁邊 - 傳送
standalone.html以透過電子郵件或聊天快速分享 - 加入描述性圖片替代文字 以提升無障礙性
- 在不同瀏覽器中測試 匯出的 HTML