设置
VMark 的设置面板让你可以自定义编辑器的方方面面。使用 Mod + , 或通过菜单栏中的 VMark > 设置 打开。
设置窗口的侧边栏按字母顺序(依英文名称)列出各章节,"关于"在底部,"高级"显示时位于其下方。更改立即生效——没有保存按钮。
使用侧边栏顶部的 搜索框,可按名称或描述在所有面板中筛选设置——匹配的行会集中显示,你无需知道某个设置位于哪个类别。要将所有设置恢复为出厂默认值,请使用"关于"部分中的 恢复默认值。
外观
控制视觉主题和窗口行为。
主题
从六种颜色主题中选择。活动主题以其色块周围的圆环标示。
| 主题 | 背景色 | 风格 |
|---|---|---|
| White | #FFFFFF | 纯净白色,对比度最高 |
| Paper | #EEEDED | 温暖的新闻纸色(默认) |
| Mint | #CCE6D0 | 柔和绿色,护眼 |
| Sepia | #F9F0DB | 书页纸色,适合长时间阅读 |
| Night | #23262B | 深石板色,适合弱光环境 |
| Solarized | #002B36 | Solarized Dark,经典配色 |
Windows 10 和 Linux 仅提供 White 与 Night
在 Windows 10 和 Linux 上,标题栏由系统绘制,而系统只能呈现浅色或深色。因此这两个平台只提供 White 和 Night,无法与系统窗口边框匹配的主题会显示为二者中较接近的一个:Paper、Mint 和 Sepia 显示为 White,Solarized 显示为 Night。你保存的选择不会被更改——在 macOS 和 Windows 11 上可以使用全部主题。在 Windows 11 上,标题栏会采用主题本身的颜色;菜单栏仍以浅色或深色绘制。
跟随系统外观
| 设置 | 描述 | 默认值 |
|---|---|---|
| 跟随系统外观 | 随系统自动在浅色与深色主题之间切换 | 关闭 |
启用后,单一的主题行会被两行取代——浅色主题(系统处于浅色模式时使用,默认 Paper)和 深色主题(深色模式时使用,默认 Night)。系统外观一变化,VMark 立即在两者之间切换;你手动选择的主题会被保留,并在关闭此选项时恢复。
侧边栏
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 侧边栏样式 | 侧边栏与工作区栏的外框样式。全高像 macOS 自带的侧边栏一样贴合窗口边缘,并以细分隔线与编辑区分开;卡片以圆角和阴影悬浮于窗口内。同样适用于设置窗口 | 全高 | 全高、卡片 |
窗口
| 设置 | 描述 | 默认值 |
|---|---|---|
| 在标题栏显示文件名 | 在 macOS 窗口标题栏显示当前文件名。仅 macOS——其他平台隐藏此设置,因为 Windows 和 Linux 始终在系统标题栏中显示文件名 | 关闭 |
| 在窗口名称中显示文件夹 | 在窗口名称中加入所在文件夹,例如 docs | readme.md。仅 macOS——用于区分文件同名的窗口 | 关闭 |
在 macOS 上,VMark 在系统标题栏之上绘制自己的标题栏,因此文件名是该标题条中的可选元素。在 Windows 和 Linux 上,系统会在窗口上方绘制真正的标题栏:文件名(有未保存的更改时带 •)始终显示在那里,VMark 不会再添加自己的标题条。
在 macOS 上,系统标题栏的文字保持隐藏,但程序坞的窗口预览、“窗口”菜单和调度中心仍会读取窗口名称。无论这些设置如何,它们始终能获得文件名。
专注模式
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 暗化程度 | 专注模式下非聚焦内容的暗化强度。标准 保留默认的仅颜色暗化;强 和 更强 在此基础上逐级降低不透明度 | 标准 | 标准、强、更强 |
编辑器
排版、显示、编辑行为、空白字符和大文件设置。
排版
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 拉丁字体 | 拉丁文(英文)字体族 | 系统默认 | 系统默认、Athelas、Palatino、Georgia、Charter、Literata——以及任何已安装的字体 |
| 中日韩字体 | 中文、日文、韩文字体族 | 系统默认 | 系统默认、PingFang SC、Songti SC、Kaiti SC、Noto Serif CJK、Source Han Sans——以及任何已安装的字体 |
| 等宽字体 | 代码和等宽文本的字体族——集成终端也使用此字体 | 系统默认 | 系统默认、SF Mono、Monaco、Menlo、Consolas、DejaVu Sans Mono、Liberation Mono、Ubuntu Mono、Noto Sans Mono、Noto Sans Mono CJK SC、JetBrains Mono、Fira Code、SauceCodePro NFM、IBM Plex Mono、Hack、Inconsolata——以及任何已安装的字体 |
| 字号 | 编辑器内容的基础字号 | 18px | 14px、16px、18px、20px、22px |
| 行高 | 行间垂直间距 | 1.8(宽松) | 1.4(紧凑)、1.6(正常)、1.8(宽松)、2.0(宽敞)、2.2(超宽) |
| 块间距 | 块级元素(标题、段落、列表)之间的视觉间距,以行高的倍数计算 | 1x(正常) | 0.5x(紧凑)、1x(正常)、1.5x(宽松)、2x(宽敞) |
| 中日韩字符间距 | 中日韩字符之间的额外间距,以 em 为单位 | 关闭 | 关闭、0.02em(微妙)、0.03em(轻微)、0.05em(正常)、0.08em(宽)、0.10em(更宽)、0.12em(超宽) |
使用你自己安装的字体
上面列出的名称只是精选列表,而不是全部。三个字体选择器都带有一个 已安装字体 分区,列出本机上的所有字体族,因此你安装的字体——霞鹜文楷、Iosevka、思源宋体——与内置字体的选择方式完全相同。
在列表末尾选择 自定义… 即可改为输入字体族名称。请使用系统报告的准确名称(macOS:字体册;Windows:设置 → 个性化 → 字体)——霞鹜文楷(LXGW WenKai)的名称是 LXGW WenKai。名称输入完整后字体立即生效;如果没有任何变化,说明该名称与已安装的字体族不匹配。包含引号、逗号、分号或括号的名称会被拒绝,该行会给出提示。
已安装字体仅限 macOS
macOS 会为你列出所有已安装的字体族。在 Windows 和 Linux 上该分区为空,需通过 自定义… 输入——输入字体族名称的方式在三个平台上完全相同。
所选字体会沿用到 PDF 导出中,因为 PDF 导出使用同一引擎和同样的字体进行渲染。HTML 导出无法打包你机器上的字体,因此导出的页面会回退到读者自己的字体,除非对方也安装了相同的字体族。
显示
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 编辑器宽度 | 最大内容宽度。较大的值适合大显示器;较小的值提高可读性 | 50em(中等) | 36em(紧凑)、42em(窄)、50em(中等)、60em(宽)、80em(超宽)、无限制 |
同样的宽度,拉丁文与中日韩文字读起来不同
编辑器宽度以 em 为单位,因此每行能容纳的字符数取决于文字系统:在 50em 下,一行拉丁文约容纳 90–100 个字符(约为排版师所推荐的 45–75 字符行长的 2 倍,适合双栏编辑器),而一行中日韩文字约容纳 50 个全角字符——正好落在中文传统的 40–60 字范围内。如果你主要写拉丁文正文并希望获得书籍般的行长,请选择 36–42em;对于以中日韩文字为主的文档,默认值已经是经典行长。
TIP
18px 字号下的 50em 约为 900px——对大多数显示器来说是舒适的阅读宽度。
行为
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| Tab 大小 | 按 Tab 时插入的空格数 | 2 个空格 | 2 个空格、4 个空格 |
| 在新标签页中打开文件 | 在新标签页中打开已有文件,而不是复用当前的空白标签页 | 关闭 | 开启/关闭 |
| 启用自动配对 | 输入开括号时自动插入对应的闭括号和引号 | 开启 | 开启/关闭 |
| 中日韩括号 | 自动配对中日韩专用括号如 「」 【】 《》,仅在启用自动配对时可用 | 自动 | 关闭、自动 |
| 包含弯引号 | 自动配对 “” 和 ‘’,并把输入的直引号 " 或 ' 转换为一对弯引号,可能与某些输入法的智能引号功能冲突,当中日韩括号设为"自动"时显示 | 开启 | 开启/关闭 |
同时配对 " | 输入右双引号 " 时也插入 "" 配对,当你的输入法在开闭引号之间交替时很有用,启用弯引号时显示 | 关闭 | 开启/关闭 |
| 复制格式 | 从所见即所得模式复制时,纯文本剪贴板槽使用的格式 | 纯文本 | 纯文本、Markdown |
| 选中即复制 | 选中文本时自动复制到剪贴板 | 关闭 | 开启/关闭 |
空白字符
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 保存时的行尾符 | 控制保存文件时如何处理行尾符 | 保留现有 | 保留现有、LF (\n)、CRLF (\r\n) |
| 换行视为硬换行 | 将段落内的单个换行视为硬换行(不影响块之间的空行) | 关闭 | 开启/关闭 |
| 保留连续换行 | 保持多个空白行,而不是合并 | 开启 | 开启/关闭 |
| 保存时的硬换行样式 | 硬换行在保存的 Markdown 文件中的表示方式 | 保留现有 | 两个空格(推荐)、保留现有、反斜杠(\) |
显示 <br> 标签 | 在编辑器中可视化显示 HTML 换行标签 | 关闭 | 开启/关闭 |
| 显示不可见字符 | 可视化显示空白字符:空格显示为 ·,制表符显示为 →(仅源码模式),软换行显示为 ↓(仅源码模式),硬换行显示为 ⏎。打印时隐藏。切换:F3 或 视图 → 显示不可见字符。 | 关闭 | 开启/关闭 |
TIP
两个空格是兼容性最好的硬换行样式——在 GitHub、GitLab 和所有主流 Markdown 渲染器上均有效。反斜杠样式在 Reddit、Jekyll 和某些旧版解析器上可能失效。
大文件
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 自动源码模式 | 以源码模式打开大文件 —— 超过 1 MB 的文件,或估算块数达到 1,200 以上的 Markdown(跳过所见即所得以保持流畅性能)。你随时可以从状态栏切换到所见即所得 | 开启 | 开启/关闭 |
| 大于此大小时警告 | 打开超过 5 MB 的文件前显示确认提示。50 MB 及以上的文件始终会被拒绝 | 开启 | 开启/关闭 |
大文件的完整处理方式请参阅大文件。
Markdown
粘贴行为、布局和 HTML 渲染设置。
粘贴与输入
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 在搜索中启用正则 | 在查找与替换栏显示正则切换按钮 | 开启 | 开启/关闭 |
| 剪贴板粘贴处理 | 粘贴时如何处理来自剪贴板的内容。智能 将 HTML 转换为 Markdown 并检测 Markdown 语法;纯文本 始终粘贴纯文本;富文本 保留原始 HTML 格式 | 智能 | 智能、纯文本、富文本 |
| 所见即所得中粘贴 Markdown | 向所见即所得编辑器粘贴看起来像 Markdown 的文本时,自动转换为富文本内容 | 自动 | 自动、关闭 |
布局
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 默认拆分源码/预览 | 以源码与实时预览并排分屏的方式打开 Markdown 文件(否则为所见即所得)。可用 Shift + F6 或 视图 → Markdown 分屏视图 按会话切换 | 关闭 | 开启/关闭 |
| 块元素字号 | 列表、引用块、表格、提示块和详情块的相对字号 | 100% | 100%、95%、90%、85% |
| 标题对齐 | 标题的文本对齐方式。仅作用于编辑器——不应用于导出或打印 | 左对齐 | 左对齐、居中 |
| 图片和图表边框 | 是否在图片、Mermaid 图表和数学块周围显示边框。仅作用于编辑器——不应用于导出或打印 | 无 | 无、始终、悬停时 |
| 图片和表格对齐 | 块图片和表格的水平对齐方式。仅作用于编辑器——不应用于导出或打印 | 居中 | 居中、左对齐 |
| 表格适应宽度 | 将所有表格限制在编辑器宽度内,而不是允许水平滚动 | 关闭 | 开启/关闭 |
| 代码块行号 | 在所见即所得编辑器的代码块内显示行号。与视图菜单中的 行号 相互独立,后者控制源码/分屏编辑器的行号栏 | 关闭 | 开启/关闭 |
Lint
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 启用 Markdown 检查 | 检查常见 Markdown 问题(损坏的链接、缺少 alt 文本、标题层级跳跃、未关闭的代码围栏等) | 开启 | 开启/关闭 |
完整规则列表和严重级别请参阅 Markdown 检查。
HTML 渲染
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 富文本中的原始 HTML | 控制是否在所见即所得模式下渲染原始 HTML 块 | 已清理 | 隐藏、已清理、已清理 + 样式 |
| 允许的 HTML 标签 | 渲染的标签集合范围 | 严格 | 严格、扩展 |
| 额外允许这些标签 | 额外允许的标签名,以逗号分隔 | (空) | 例如 kbd, samp, var |
TIP
隐藏 会折叠原始 HTML,不渲染任何内容。已清理 在去除危险标签后渲染 HTML。已清理 + 样式 额外保留内联 style 属性中的安全子集。
严格 只允许一小组保守的标签。扩展 额外渲染 <svg>(及其安全的子元素)、<figure>/<figcaption>、<details>/<summary> 以及其他语义/结构标签——这些同样都会经过清理。使用 额外允许这些标签 可以在此基础上添加特定标签(例如 kbd, samp, var)。
WARNING
无论这些设置如何,危险标签(<script>、<style>、<iframe>、<form>、事件处理器等)始终会被去除——自定义标签字段无法重新启用它们。允许列表的范围只影响所见即所得预览;文件中的原始 HTML 永远不会被修改。
文件与图片
文件浏览器、保存、文档历史、图片处理和文档工具。
工作区
| 设置 | 描述 | 默认值 |
|---|---|---|
| 工作区侧栏 | 显示左侧工作区侧栏,并将多个工作区和零散文件保留在同一窗口中 | 关闭 |
侧栏带来的功能请参阅工作区导轨。
文件浏览器
前两项设置仅在打开工作区(文件夹)时有效,并按工作区分别保存。
| 设置 | 描述 | 默认值 |
|---|---|---|
| 显示隐藏文件 | 在文件浏览器侧边栏中显示点文件和隐藏系统项 | 关闭 |
| 显示所有文件 | 在文件浏览器中显示非 Markdown 文件,非 Markdown 文件会用系统默认应用打开 | 关闭 |
| 显示文件扩展名 | 在侧边栏、标签栏和标题栏中显示完整文件名——显示 notes.md 而非 notes。无论是否打开工作区都适用 | 开启 |
关闭 显示文件扩展名 只会隐藏 VMark 能识别的扩展名。VMark 无法打开的文件无论如何都保留后缀,因此你看到的名称总是磁盘上真实存在的。
退出行为
| 设置 | 描述 | 默认值 |
|---|---|---|
| 确认退出 | 需要按两次 Cmd+Q(或 Ctrl+Q)才能退出,防止意外退出 | 开启 |
| 关闭时最小化到托盘 | 仅 Windows。 关闭最后一个窗口时,VMark 继续在系统托盘中运行,而不是退出 | 关闭 |
关闭时最小化到托盘 只改变最后一个窗口的行为。打开多个窗口时,关闭其中一个仍会关闭它;只有最后一次关闭——原本会退出 VMark 的那一次——现在会把它停放到托盘中。没有任何内容被关闭,因此未保存的工作会原样保留。
- 左键单击 托盘图标可恢复 VMark。
- 右键单击 可选择 显示 VMark 和 退出 VMark。从托盘退出时会先恢复窗口,因此任何未保存更改的提示都会出现在你可以回应的地方。
Ctrl+Q仍照常退出。- 在 VMark 位于托盘中时关闭此设置,会在图标消失前恢复窗口,因此绝不会让 VMark 在没有窗口也没有图标的情况下运行。
此设置不会出现在 macOS 或 Linux 上。
保存
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 启用自动保存 | 编辑后自动保存文件 | 开启 | 开启/关闭 |
| 保存时写入标识块 | 允许 VMark 向文件的 frontmatter 插入 vmark: 标识块,并在工作区创建 .vmark 文件夹,以便一致性层跟踪该文档。适用于所有写入:保存、AI 与 MCP 编辑、恢复早期版本和新建文件。关闭时不会插入标识块,也不会创建 .vmark 文件夹;已有 .vmark 的工作区会继续记录其所跟踪文档的变更——即它此前记录过的文档,或本身已带有 vmark: 标识块的文档,例如你移动或检出的已跟踪文件。参见一致性 | 关闭 | 开启/关闭 |
| 保存间隔 | 自动保存之间的时间,仅在启用自动保存时可用 | 30 秒 | 10 秒、30 秒、1 分钟、2 分钟、5 分钟 |
| 保留文档历史 | 跟踪文档版本以便撤销和恢复 | 开启 | 开启/关闭 |
| 最大版本数 | 每个文档保留的历史快照数量 | 50 个版本 | 10、25、50、100 |
| 保留版本时长 | 历史快照在被清除前的最长保存时间 | 7 天 | 1 天、7 天、14 天、30 天 |
| 合并窗口 | 此时间窗口内的连续自动保存合并为单个快照,减少存储噪音 | 30 秒 | 关闭、10 秒、30 秒、1 分钟、2 分钟 |
| 历史的最大文件大小 | 超过此阈值的文件跳过自动保存产生的历史快照;手动保存、MCP 保存以及恢复版本前的安全副本始终保留 | 512 KB | 256 KB、512 KB、1 MB、5 MB、无限制 |
图片
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 粘贴时自动调整大小 | 保存到资产文件夹前自动调整大图片。值为最大像素尺寸 | 关闭 | 关闭、800px、1200px、1920px(全高清)、2560px(2K) |
| 复制到资产文件夹 | 将粘贴或拖放的图片复制到文档的资产文件夹,而不是嵌入 | 开启 | 开启/关闭 |
| 关闭时清理未使用的图片 | 自动删除资产文件夹中文档不再引用的图片。关闭文档、窗口或应用时均会执行。同一文件夹中其他文档仍在引用的图片会被保留,被移除的图片会进入系统废纸篓 | 关闭 | 开启/关闭 |
TIP
如果你经常粘贴截图或照片,请启用 粘贴时自动调整大小——它无需手动调整即可保持资产文件夹轻量。
文档工具
VMark 检测 Pandoc 以支持导出为其他格式(DOCX、EPUB、LaTeX 等)。点击 检测 扫描你系统上的 Pandoc。找到后会显示其版本和路径。
所有导出选项的详情请参阅导出与打印。
集成
MCP 服务器和 AI 提供商配置。
MCP 服务器
MCP(模型上下文协议)服务器允许外部 AI 助手(如 Claude Code 和 Cursor)以编程方式控制 VMark。
| 设置 | 描述 | 默认值 |
|---|---|---|
| 启用 MCP 服务器 | 启动或停止 MCP 服务器。运行时,状态徽章显示端口和已连接的客户端 | 开启(切换) |
| 启动时启动 | VMark 打开时自动启动 MCP 服务器 | 开启 |
| 自动批准保存到新位置和精灵结果 | 允许 MCP 客户端无需询问即可将文档保存到新位置,并允许精灵直接应用其结果而不显示预览。关闭时,MCP 保存到新路径的请求会被拒绝,并以提示通知你。MCP 对文档的写入从不受此设置限制——每次写入都会记入智能体编辑历史,可从状态栏的 MCP 写入历史中恢复 | 关闭 |
服务器运行时,面板还会显示:
- 端口——自动分配;AI 客户端通过配置文件发现端口
- 版本——MCP 服务器附属程序版本
- 工具/资源——可用的 MCP 工具和资源数量
- 已连接的客户端——当前连接的 AI 客户端数量
在 MCP 服务器部分下方,你可以一键将 VMark 的 MCP 配置安装到支持的 AI 客户端(Claude Desktop、Claude Code、Codex CLI、Gemini CLI)。
AI 提供商
配置驱动 AI 精灵的 AI 提供商。同一时间只能激活一个提供商。
CLI 提供商——使用本地安装的 AI CLI 工具(Claude、Codex、Gemini)。点击 检测 扫描 $PATH 中可用的 CLI。CLI 提供商使用你的订阅计划,无需 API 密钥。
REST API 提供商——直接连接 API:Anthropic、OpenAI、OpenAI 兼容服务(DeepSeek、Groq、OpenRouter……)、Google AI,或本地的 Ollama 服务器(Ollama API)。每个都需要模型名称和 API 密钥——但 Ollama 的密钥是可选的。除 Google AI 外都还需要端点,有标准端点的提供商已预先填好(OpenAI 兼容槽位没有标准端点,需要你自行填写)。
各提供商的详细设置说明请参阅 AI 提供商。
格式
非默认格式适配器的可选开关,以及只读代码标签页的外部编辑器命令。
Markdown、纯文本和 YAML/YML 始终已注册——这是默认的稳定选项。其他所有适配器默认关闭,避免升级时出乎意料。切换开关后,注册表即时重建;已打开的标签页会以正确的适配器重新挂载,无需重启。
完整的格式列表及其预览说明,请参阅支持的格式。
格式支持
| 开关 | 默认 | 启用内容 |
|---|---|---|
| 数据格式 | 关闭 | .json、.jsonl、.toml——分栏源码 + 可导航树。支持 Cargo.toml、package.json、pyproject.toml 的架构感知预览。 |
| 图表 & SVG | 关闭 | .mmd(Mermaid)和 .svg——分栏源码 + 净化后的实时渲染。 |
| HTML 预览 | 关闭 | .html 和 .htm——沙盒 iframe 预览(空 sandbox="" 允许列表、DOMPurify、CSP <meta>)。其安全审核签署仍在进行中,预览中也会如此提示——参见 HTML 安全模型。 |
| 代码查看器 | 关闭 | 12 种只读查看器(.ts、.tsx、.js、.jsx、.py、.rs、.go、.css、.sh、.bash、.rb、.lua)。在带语法高亮的查看器中打开,提供 启用编辑 和 在外部编辑器中打开 按钮。 |
当某类别关闭时,匹配的扩展名会回退到纯文本模式,文件仍然可以打开——只是没有架构视图。
默认视图模式
可预览的文件(HTML、SVG、Mermaid、JSON、YAML、TOML)以三种视图模式之一打开:
| 选项 | 效果 |
|---|---|
| 源代码 | 可编辑的源码窗格,占满宽度。 |
| 分屏(默认) | 源码与预览并排显示。 |
| 预览 | 只读渲染,占满宽度。 |
这是新打开标签页的默认值;每个标签页会记住自己的选择,你可以用屏幕上的切换按钮或 F6 / Shift + F6 切换任意标签页。
外部编辑器
对于只读代码标签页上的 在外部编辑器中打开 按钮,在此选择要启动的编辑器:已知编辑器的名称(code、zed、subl、vim 等),或者应用包(例如 /Applications/Visual Studio Code.app)或可执行文件的完整路径。Shell、解释器和终端模拟器会被拒绝,不存在的路径也会被拒绝。
图形界面设置优先于任何环境变量——显式优于隐式。留空则使用环境变量回退链 $VMARK_EXTERNAL_EDITOR → $VISUAL → $EDITOR → 平台默认。完整的解析顺序和安全关口说明,请参阅在外部编辑器中打开。
一次性升级提示
首次升级至多格式支持后启动时,VMark 会显示一个无阻塞的提示,引导你前往 设置 → 格式。此提示每次安装只显示一次——显示或关闭后不再出现。
文件类型覆盖
除了类别开关,你还可以通过命令面板覆盖单个文件族的打开方式——设置文件类型:纯文本 / Markdown / 恢复默认。覆盖按文件族存储(按扩展名,或对 .env 这类文件按点文件主名),并在会话之间保留。参见 VMark 如何判断文件类型。
格式 面板会列出你设置的每一项覆盖,格式为 key → format。用条目的 × 按钮删除单项,或使用 全部清除 一次性删除——被删除的条目会回退到内置规则。
语言
界面语言,以及中日韩(中文、日文、韩文)格式化规则。
界面语言
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 界面语言 | 更改菜单、标签和消息的界面语言,立即生效 | 系统语言 | English、简体中文、繁體中文、日本語、한국어、Español、Français、Deutsch、Italiano、Português (Brasil) |
首次启动时,VMark 会从系统的首选语言列表中选取第一个它支持的语言;若都不匹配,则使用英语。你在这里选择语言后,该选择会被保留。
中日韩格式化
以下规则在你对选中内容运行 格式 → 中日韩文字 → 格式化选中内容(Cmd+Shift+F)或对整个文件运行 格式 → 中日韩文字 → 格式化整个文件(Alt+Cmd+Shift+F)时应用。
TIP
语言部分包含 20 多个细粒度的格式化开关。每条规则的完整说明和示例请参阅中日韩格式化。
全角标准化
| 设置 | 描述 | 默认值 |
|---|---|---|
| 转换全角字母/数字 | 将全角字母数字字符转换为半角(如 ABC 转为 ABC) | 开启 |
| 标准化标点宽度 | 将中日韩字符之间的全角逗号和句号转换为半角 | 开启 |
| 转换括号 | 内容为中日韩时将全角括号转换为半角 | 开启 |
| 转换方括号 | 内容为中日韩时将半角方括号转换为全角 【】 | 关闭 |
间距
| 设置 | 描述 | 默认值 |
|---|---|---|
| 添加中日韩-英文间距 | 在中日韩字符和拉丁字符之间插入空格 | 开启 |
| 添加中日韩-括号间距 | 在中日韩字符和括号之间插入空格 | 开启 |
| 删除货币间距 | 删除货币符号后的多余空格(如 $ 100 变为 $100) | 开启 |
| 删除斜杠间距 | 删除斜杠周围的空格(如 A / B 变为 A/B),保留 URL | 开启 |
| 合并多余空格 | 将多个连续空格减少为单个空格 | 开启 |
破折号与引号
| 设置 | 描述 | 默认值 |
|---|---|---|
| 转换破折号 | 将中日韩字符之间的双连字符(--)转换为破折号(——) | 开启 |
| 修复破折号间距 | 确保破折号周围有适当的间距 | 开启 |
| 转换直引号 | 将直引号 " 和 ' 转换为弯引号 | 开启 |
| 引号样式 | 智能引号转换的目标样式 | 弯引号 "" '' |
| 上下文感知引号 | 在中日韩文字周围使用弯引号,但在纯拉丁文本中保留直引号,仅在启用转换直引号时可用 | 开启 |
| 引号切换行为 | 引号样式切换命令在各样式之间的循环方式——简单 在直引号与你的首选样式之间切换;完整循环 轮流切换所有样式 | 简单 |
| 修复双引号间距 | 规范化双引号周围的间距 | 开启 |
| 修复单引号间距 | 规范化单引号周围的间距 | 开启 |
| 中日韩直角引号 | 将繁体中文和日文文本中的弯引号转换为直角括号 「」,仅在引号样式为"弯引号"时可用 | 关闭 |
| 嵌套直角引号 | 将 「」 内的嵌套单引号转换为 『』 | 关闭 |
章节处理
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 跳过参考章节 | 运行中日韩格式化时不处理 ## References 和 ## Further Reading 章节——适用于引用文本需要保持原样的学术文档 | 关闭 | 开启/关闭 |
清理
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 限制连续标点 | 限制重复的标点符号如 !!! | 关闭 | 关闭、单个(!! 变为 !)、两个(!!! 变为 !!) |
| 删除行尾空格 | 删除行末的空格 | 开启 | 开启/关闭 |
| 规范化省略号 | 将带空格的点(. . .)转换为正确的省略号(...) | 开启 | 开启/关闭 |
| 合并换行 | 将三个或更多连续换行减少为两个 | 关闭 | 开启/关闭 |
快捷键
查看和自定义所有键盘快捷键。快捷键按类别分组(文件、编辑、视图、格式等)。
- 搜索——按名称、类别或按键组合过滤快捷键
- 点击快捷键 更改其绑定,按下新的组合键后确认
- 重置——恢复单个快捷键的默认值,或一次性重置所有快捷键
- 导出/导入——将自定义绑定保存为 JSON 文件,并在另一台机器上导入
完整的默认快捷键参考请参阅键盘快捷键。
终端
配置集成终端面板。使用 Ctrl + ` 打开终端。
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| Shell | 使用哪个 Shell,需要重启终端才能生效。已保存但不再可用的 Shell 会显示为 (不可用),并改用默认值 | 系统默认 | 系统上自动检测到的 Shell(如 zsh、bash、fish) |
| 面板位置 | 终端面板放置的位置 | 自动 | 自动(基于窗口纵横比)、顶部、底部、左侧、右侧 |
| 面板大小 | 终端占用可用空间的比例,拖动调整面板大小也会更新此值 | 40% | 10% 至 80% |
| 字号 | 终端中的文字大小 | 13px | 10px 至 24px |
| 行高 | 终端行间垂直间距 | 1.2(紧凑) | 1.0(紧密)至 2.0(超宽) |
| 光标样式 | 终端光标的形状 | 竖线 | 竖线、方块、下划线 |
| 光标闪烁 | 终端光标是否闪烁 | 开启 | 开启/关闭 |
| 选中即复制 | 自动将选中的终端文本复制到剪贴板 | 关闭 | 开启/关闭 |
| 自动渲染对话记录 | 在终端 CLI 旁渲染 Claude/Codex 的 Markdown、表格和 Mermaid 图表。启用时会在 Claude Code 和 Codex 的配置中添加本地 SessionStart 钩子;启用后请重启正在运行的 CLI 会话 | 关闭 | 开启/关闭 |
| WebGL 渲染器 | 使用 GPU 加速渲染终端,如遇输入法输入问题请禁用,需要重启终端。仅限 macOS 和 Windows,Linux 始终使用 DOM 渲染器 | 开启 | 开启/关闭 |
| 远程剪贴板(OSC 52) | 允许在终端中运行的程序——通过 ssh 或在 tmux 内——复制到你的系统剪贴板。该通道只写:读取剪贴板的请求始终被拒绝,因为终端中打印的任何输出都可能发出这种请求 | 开启 | 开启/关闭 |
| 回滚缓冲区 | 每个会话在滚动历史中保留的输出行数,数值越大占用内存越多 | 5,000 | 1,000 / 5,000 / 10,000 / 50,000 |
| 屏幕阅读器模式 | 将终端输出提供给辅助技术(VoiceOver)。出于性能考虑默认关闭 | 关闭 | 开启/关闭 |
这里还有两个平台特定的开关,默认均为开启:将 Option 用作 Meta 键(仅 macOS——将 Option 键视为 Meta,emacs、tmux 等工具在 Alt 前缀快捷键和按词移动时需要它;如果你需要用 Option 死键输入重音字母,例如 Option + E,请关闭它)和 Shell 集成(在 Windows 上隐藏——向 zsh 和 bash 注入命令标记,以支持提示符导航、退出状态标记和当前目录跟踪;从新的终端会话开始生效)。
无障碍
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 终端响铃 | 终端响铃(BEL)的提示方式。视觉 在会话标签上标记后台活动;声音 播放一声轻柔的蜂鸣,并且(对于后台会话)同时标记标签,便于你找到它;关闭 则忽略响铃。对正在运行的会话实时生效 | 视觉 | 关闭、视觉、声音 |
| 未聚焦时通知 | 当某个 VMark 窗口未获得焦点而其中的终端响铃时,显示系统通知(注明该窗口的文档)——例如 Claude Code 完成一轮回复。这样无需逐个盯着窗口,也能跟踪多个窗口中的 Claude Code。首次使用时需要授予通知权限 | 开启 | 开启/关闭 |
| 最小对比度 | 将暗淡的终端文本提升到相对其背景的最小对比度。调高可提升可读性;关闭 则禁用提升。对正在运行的会话实时生效 | WCAG AA 级(4.5:1) | 关闭、WCAG AA 级(4.5:1)、WCAG AAA 级(7:1)、最大 |
有关会话、键盘快捷键和 Shell 环境的更多信息,请参阅集成终端。
关于
显示应用版本、网站和 GitHub 仓库链接,以及更新管理。第三方声明 链接会用系统默认的文本文件应用打开 VMark 所附带的开源软件的许可证文本。
更新
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 自动更新 | 定期检查新版本 | 开启 | 开启/关闭 |
| 检查频率 | 检查更新的频率,仅在开启自动更新时可用 | 启动时 | 启动时、每天、每周、仅手动 |
| 自动下载更新 | 有新版本时在后台下载 | 关闭 | 开启/关闭 |
| 立即检查 | 手动触发更新检查 | — | — |
有可用更新时,会显示一张卡片,显示新版本号、发布日期和版本说明。你可以 下载 更新、跳过 此版本,或——下载完成后——重启以更新。
更新与你安装 VMark 的方式一致
更新程序下载的是与你安装时相同的包格式,而不是每个平台固定一种:
| 你安装的是 | 更新程序获取的是 |
|---|---|
macOS .dmg | 已签名的应用包 |
Windows .exe(NSIS) | .exe 安装程序 |
Windows .msi | .msi 安装包 |
Linux .deb | .deb 软件包 |
Linux .rpm | .rpm 软件包 |
| Linux AppImage | AppImage |
在 Linux 上,更新 .deb 或 .rpm 安装会调用系统包管理器,因此会提示你进行身份验证——安装系统软件包需要 root 权限。AppImage 更新会原地替换文件,无需提示。
如果更新卡住
检查和下载都要经过网络,而一个挂起而非直接失败的连接可能会让更新永远处于进行中。如果检查一分钟没有进展,或者下载或安装三分钟没有进展,VMark 会在文档窗口中显示一条常驻的 更新已停滞 通知。其 重试 按钮会让更新程序回到空闲状态,以便你再次尝试——本部分中的 立即检查 或下一次自动检查,都会重新开始一次全新的检查。
更新活动会写入日志文件,因此如果问题反复出现,值得将日志附在错误报告中:
| 平台 | 日志位置 |
|---|---|
| macOS | ~/Library/Logs/app.vmark/ |
| Windows | %LOCALAPPDATA%\app.vmark\logs\ |
| Linux | ~/.local/share/app.vmark/logs/ |
重置
| 设置 | 描述 |
|---|---|
| 恢复默认值 | 将这些面板中的设置恢复为默认值。会先出现确认提示——此操作无法撤销 |
有三类内容单独存储,不会被重置:键盘快捷键自定义(请在快捷键面板中使用 全部重置)、你的 AI 提供商配置,以及按工作区保存的文件浏览器设置(显示隐藏文件、显示所有文件)。界面语言会恢复为系统语言。
高级
TIP
高级部分默认显示——它承载着内嵌浏览器的关闭开关,而该浏览器默认开启。在设置窗口中按 Ctrl + Option + Cmd + D 可隐藏它,再按一次即可重新显示。
开发者和系统级配置。
链接协议
| 设置 | 描述 | 默认值 |
|---|---|---|
| 自定义链接协议 | VMark 视为链接的额外 URL 协议,以标签形式输入每个协议 | obsidian、vscode、dict、x-dictionary |
这个列表有两个作用。插入链接时,剪贴板中使用这些协议的 URL 会像 https:// 一样被识别为链接。打开链接时,只有协议为 http、https、mailto 或在此列表中的链接,VMark 才会交给系统打开——因此 obsidian://open?vault=... 和 vscode://file/... 链接会在对应的应用中打开,其他协议则被拒绝。少数协议无论列表如何都不能被启用:javascript:、data:、file: 等。
你删除的默认协议会保持删除状态。之后的 VMark 版本新增的默认协议,会在该版本首次启动时加入你的列表,且只加入一次。
性能
| 设置 | 描述 | 默认值 |
|---|---|---|
| 同时保持两个编辑器活跃 | 同时挂载所见即所得和源码模式编辑器,以加快模式切换,会增加内存使用 | 关闭 |
一致性
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 语义检查置信度 | 检查的答案被记录为判定之前所需的把握程度。低于该值时,答案仍会保留,但被标记为未知 | 0.9 | 0.7、0.8、0.9、0.95 |
什么是检查以及判定如何记录,请参阅一致性。
工作流文件
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 获取 Action 元数据 | 允许 VMark 从引用的 GitHub Actions 获取 action.yml,以填充结构化编辑器中的 with: 表单。关闭后,工作流编辑器完全离线 | 开启 | 开启/关闭 |
| 可用时使用 actionlint | 如果 actionlint 可执行文件位于 PATH 中,则对工作流文件运行它以获得更丰富的诊断。未安装该可执行文件时不起作用 | 开启 | 开启/关闭 |
工作流
GitHub Actions 查看器没有开关:打开 .github/workflows/ 下的文件就会显示图和表单编辑器,源码窗格的辅助功能(表达式补全、光标与画布同步、uses: 跳转到定义)也会随之加载。这里保留的是查看器唯一的一项偏好设置,以及独立的执行引擎。
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 保存时保留 YAML 格式 | 通过表单面板保存工作流编辑时,借助 CST 往返管线保留原 YAML 的注释、锚点、键序和空行。关闭时使用紧凑序列化器(更快但有损) | 开启 | 开启/关闭 |
| 工作流引擎 | 运行 VMark 自己的 YAML 工作流文件:工作流文件打开时,源码旁会显示它的步骤图和运行 / 取消工具栏,工作流精灵也可以执行。步骤可能调用 AI 提供商并写入文件,因此在你主动开启之前保持关闭 | 关闭 | 开启/关闭 |
引擎不会改变查看器显示的内容:无论引擎是否开启,GitHub Actions 文件都会在查看器中打开;引擎关闭时,VMark 工作流文件显示为普通的 YAML 树。引擎关闭时,VMark 还会直接拒绝工作流执行请求,而不只是隐藏按钮——包括通过 MCP 发来的请求——并报告“工作流引擎已在设置中关闭”。
这两行都位于 开发者工具 之下(见下文)——开启开发者工具即可显示它们。查看器请参阅 Workflow 查看器,引擎请参阅 Genie 工作流。
内嵌浏览器
| 设置 | 描述 | 默认值 | 选项 |
|---|---|---|---|
| 内嵌浏览器 | 应用内网页浏览器(仅 macOS)。开启时,新建浏览器标签页 会出现在文件菜单和命令面板中,MCP browser 工具也可用。关闭它会关闭已打开的浏览器标签页,并撤下 AI 自动化功能 | 开启 | 开启/关闭 |
| AI 浏览器会话 | 选择 沙盒(推荐,隔离且不持久保存的 AI Cookie)或 共享配置文件(使用你本人的浏览配置,访问目标需经批准) | 沙盒 | 沙盒 / 共享 |
| 允许 AI 回环访问 | 允许 AI 导航到 localhost 和回环地址。私有局域网、元数据和链路本地地址范围仍被阻止 | 关闭 | 开启/关闭 |
这些设置位于 高级 → macOS 下,且只在 macOS 上显示。两个 AI 安全策略行只在浏览器开关开启时显示,并且不受该开关开启的影响——在你更改之前,它们会一直保持沙盒 / 阻止回环。完整功能介绍请参阅内置浏览器。
平台特定
| 设置 | 描述 | 默认值 | 平台 |
|---|---|---|---|
| 打开时清除 macOS 隔离属性 | 打开工作区时,从工作区文件夹及其中直接包含的、VMark 能打开的文件上移除 macOS 下载隔离属性(com.apple.quarantine)(不处理子文件夹)。否则在 VMark 运行时,macOS 可能会悄无声息地忽略你在访达中双击已下载文件的操作。界面中显示为 高级 → macOS 下的 打开工作区时清除下载隔离标记 | 开启 | macOS |
终端的 将 Option 用作 Meta 键 设置位于终端面板中。
开发者工具
开发者工具 是一个会持久保存的总开关,用于实验性和仅供开发的设置。开启后会显示 保存时保留 YAML 格式 行、工作流引擎 开关以及 热退出开发工具 面板(用于测试会话捕获、检查、恢复、清除和重启的按钮)。由于该开关会被保存,你启用的开发中功能在各次会话之间以及正式版本中都能保持可用——无需每次打开设置时都重新启用开发者工具。
它还会在设置之外显示知识库:视图 → 切换知识库 菜单项、命令面板命令和 Ctrl + Shift + 4 快捷键在开发者工具开启前都是隐藏的,因为目前任何平台的正式版本都没有附带该功能所需的内容服务器运行时。
| 设置 | 描述 | 默认值 |
|---|---|---|
| 开发者工具 | 启用开发者模式,并显示下列实验性和仅供开发的设置 | 关闭 |